Menu Đóng

Lab GNS3 Thực Hành Định Tuyến Tĩnh

Sơ đồ bài lap

Lệnh cấu hình định tuyến tĩnh trên router Cisco

– Dòng lệnh cơ bản
Router(config)#ip route destination_subnet subnetmask {IP_next_hop | output_interface} [AD]
Trong đó:
destination_subnet: dải mạng đích đến
subnetmask: subnetmask của mạng đích đến
IP_next_hop: địa chỉ IP đấu nối của trạm kế tiếp trên đường đi
output_interface: cổng ra trên router
AD: Chỉ số Administrative Distance của router khai báo, sử dụng trong trường hợp có cấu hình dự phòng

Cấu hình gán IP theo sơ đồ

– Cấu hình gán địa chỉ IP theo sơ đồ mạng bên trên tại Router 1
R1#conf t
R1(config)#int f0/0
R1(config)#ip address 192.168.100.254 255.255.255.0
R1(config)#no sh
R1(config)#int f0/1
R1(config)#ip address 192.168.12.1 255.255.255.252
R1(config)#no sh
R1(config)#int loopback 0
R1(config)#ip add 1.1.1.1 255.255.255.0
R1(config)#no sh
R1(config)#end

– Cấu hình gán địa chỉ IP theo sơ đồ mạng bên trên tại Router 2
R2#conf t
R2(config)#int f0/0
R2(config)#ip address 192.168.12.2 255.255.255.252
R2(config)#no sh
R2(config)#int f0/1
R2(config)#ip address 192.168.23.2 255.255.255.252
R2(config)#no sh
R2(config)#int f1/0
R2(config)#ip address dhcp
R2(config)#no sh
R2(config)#end

– Cấu hình gán địa chỉ IP theo sơ đồ mạng bên trên tại Router 3
R1#conf t
R1(config)#int f0/0
R1(config)#ip address 192.168.200.254 255.255.255.0
R1(config)#no sh
R1(config)#int f0/1
R1(config)#ip address 192.168.23.1 255.255.255.252
R1(config)#no sh
R1(config)#int loopback 0
R1(config)#ip add 2.2.2.2 255.255.255.0
R1(config)#no sh
R1(config)#end

Kiểm tra các route mà router đã biết

– Kiểm tra bảng định tuyến tại Router 1
R1#show ip route
C 1.1.1.0/24 is directly connected, Loopback0
L 1.1.1.1/32 is directly connected, Loopback0
C 192.168.12.0/30 is directly connected, FastEthernet0/1
L 192.168.12.1/32 is directly connected, FastEthernet0/1
C 192.168.100.0/24 is directly connected, FastEthernet0/0
L 192.168.100.254/32 is directly connected, FastEthernet0/0
Nhận xét: Router 1 thấy được 3 đường mạng thông qua kết nối trực tiếp, ta không
cần cấu hình định tuyến tĩnh đi đến 3 đường mạng này.

– Tương tự kiểm tra các đường mạng đã thấy tại Router 2 và Router 3
R2#show ip route
C 192.168.12.0/30 is directly connected, FastEthernet0/0
L 192.168.12.2/32 is directly connected, FastEthernet0/0
C 192.168.23.0/30 is directly connected, FastEthernet0/1
L 192.168.23.2/32 is directly connected, FastEthernet0/1
C 192.168.64.0/24 is directly connected, FastEthernet1/0
L 192.168.64.137/32 is directly connected, FastEthernet1/0
R3#show ip route
C 2.2.2.0/24 is directly connected, Loopback0
L 2.2.2.2/32 is directly connected, Loopback0
C 192.168.23.0/30 is directly connected, FastEthernet0/1
L 192.168.23.1/32 is directly connected, FastEthernet0/1
C 192.168.200.0/24 is directly connected, FastEthernet0/0
L 192.168.200.254/32 is directly connected, FastEthernet0/0

Cấu hình static tại R1 R2 và R3 để 2 đường mạng 192.168.100.0/24 và 192.168.200.0/24 thấy được nhau

– Cấu hình tại Router 1
R1(config)#ip route 192.168.200.0 255.255.255.0 192.168.12.2
– Cấu hình tại Router 2
R2(config)#ip route 192.168.100.0 255.255.255.0 192.168.12.1
R2(config)#ip route 192.168.200.0 255.255.255.0 192.168.23.1
– Cấu hình tại Router 3
R3(config)#ip route 192.168.100.0 255.255.255.0 192.168.23.2
– Kiểm tra kết nối mạng sau khi đã định tuyến.
R1##ping 192.168.200.254 source 192.168.100.254
!!!!
R3##ping 192.168.100.254 source 192.168.200.254
!!!!

Cấu hình static route để 2 đường mạng 1.1.1.0/24 và 2.2.2.0/24 thấy nhau

– Cấu hình tại Router 1
R1(config)#ip route 2.2.2.0 255.255.255.0 192.168.12.2
– Cấu hình tại Router 2
R2(config)#ip route 1.1.1.0 255.255.255.0 192.168.12.1
R2(config)#ip route 2.2.2.0 255.255.255.0 192.168.23.1
– Cấu hình tại Router 3
R3(config)#ip route 1.1.1.0 255.255.255.0 192.168.23.2
– Kiểm tra kết nối mạng sau khi đã định tuyến.
R1#ping 2.2.2.2
….
R1#ping 2.2.2.2 source 1.1.1.1
!!!!

Nguyên Lý Chọn Đường Mạng

– Giả sử ta có bảng định tuyến như bên dưới. Nếu như Router 1 nhận packet với IP đích đến là 2.2.2.2 thì thiết bị sẽ chọn lựa dòng route nào ?

R1#show ip route static
2.0.0.0/24 is subnetted, 1 subnets
S 2.2.2.0 [1/0] via 192.168.12.2
S 192.168.200.0/24 [1/0] via 192.168.12.2
=> R1 forward packet với IP src: 1.1.1.1
IP dst: 2.2.2.2 => network-id tương ứng là ?
=> Làm sao để R1 chọn được ĐÚNG dòng route ?
=> Thiết bị sử dụng ” Nguyên lý số trùng dài nhất”
00000010.00000010.00000010.00000010 <– IP dst: 2.2.2.2
11000000.10101000.11001000.00000000 <– Network 192.168.200.0/24
=> so sánh từ trái qua phải
=> không trùng khớp
00000010.00000010.00000010.000000 10 <– IP dst: 2.2.2.2
00000010.00000010.00000010.000000 00 <– Network 2.2.2.0/24
=> so sánh từ trái qua phải
=> trùng khớp nhau 30 bit và “ĐÂY LÀ ĐƯỜNG ROUTE CÓ ĐỘ TRÙNG DÀI
NHẤT NÊN ROUTER 1 SẼ SỬ DỤNG CÁCH ĐI CỦA ROUTE NÀY”

Cấu hình Static Default Route

– Default Route thường được sử dụng để thiết bị có đường Route kết nối mạng Internet.
– Default Route là đường đi cuối cùng được chọn lựa khi router không có các dòng route chi tiết để chọn lựa
– Tại Router 2, interface fastethernet 1/0 đang kết nối vào “Cloud 1” (được cấu hình kết nối vào card mạng có dây)
R2(config)# interface FastEthernet1/0
R2(config-if)# ip address 192.168.64.3 255.255.255.0
R2(config-if)# no shutdown
R2(config-if)# exit
R2(config)# ip route 0.0.0.0 0.0.0.0 192.168.64.2
+ Dòng định tuyến tĩnh mặc định tại Router 2
+ Forward gói tin đi đến Router có kết nối Internet là 192.168.64.2

– Cấu hình static default route tại R1 forward packet đi đến R2
R1(config)#ip route 0.0.0.0 0.0.0.0 192.168.12.2
– Cấu hình static default route tại R3 forward packet đi đến R2
R3(config)#ip route 0.0.0.0 0.0.0.0 192.168.23.2
– Kiểm tra kết nối
R1#ping 192.168.23.1
!!!!
=> R1 sử dụng static default route để forward packet đi đến R2
R1#ping 8.8.8.8
!!!!

Sử dụng Null Route để Deny IP packet

– Ta có thể sử dụng định tuyến để “Deny một IP hoặc Deny Network” bằng Null Route
– Cấu hình thêm một số IP secondary tại R1 và R3
R1(config)#interface loopback 0
R1(config-if)#ip address 1.1.1.2 255.255.255.0 secondary
R1(config-if)#end
R3(config)#interface loopback 0
R3(config-if)#ip add 2.2.2.3 255.255.255.0 secondary
R3(config-if)#end

– Kiểm tra kết nối
R1#ping 2.2.2.3 source 1.1.1.2
!!!!

– Router 3 cấu hình Null Route để Deny IP 1.1.1.2
R3(config)#ip route 1.1.1.2 255.255.255.255 Null 0
1.1.1.2 255.255.255.255 => “Host Route” là route để định tuyến chính xác đến một địa chỉ IP
Null 0: là interface luận lý trong thiết bị, dùng để Deny IP packet

R1#ping 2.2.2.3 source 1.1.1.2
….

R3#show ip route static
S 1.1.1.2/32 is directly connected, Null0

– Router 3 cấu hình Null Route để Deny dải IP 192.168.1.0/24
R3(config)#ip route 192.168.1.0 255.255.255.0 Null 0
=> Nếu như R3 forward packet với IP destination là 192.168.1.X thì sẽ DROP

Summary Static Route

– Summary Route:
+ Tính toán đường route đại diện cho nhiều đường route
+ Điều kiện cần: “Các đường route phải có tính chất liên tục”
=> Liên quan Design Mô Hình Mạng
– Gán thêm các card mạng loopback ở Router 3
//R3
R3(config)#int lo 1
R3(config-if)#ip add 10.0.0.1 255.255.255.0
R3(config-if)#int lo 2
R3(config-if)#ip add 10.0.1.1 255.255.255.0
R3(config-if)#int lo 3
R3(config-if)#ip add 10.0.2.1 255.255.255.0
R3(config-if)#int lo 4
R3(config-if)#ip add 10.0.3.1 255.255.255.0
R3(config-if)#

– Xác định các bit giống nhau của dãy đường mạng và thiết lập định tuyến tĩnh tại Router 1 và Router 2 đi đến bốn đường mạng đã được thêm vào tại Router 1.
10.0.0.0/24
10.0.1.0/24
|
|
10.0.3.0/24
00001010.00000000.000000 00.00000000
00001010.00000000.000000 01.00000000
00001010.00000000.000000 10.00000000
00001010.0000000
0.000000 11.00000000
11111111.11111111.111111 00.00000000 = 255.255.252.0
=> giống nhau 22 bit từ trái qua phải
11111111.11111111.1111 1100.00000000 <– subnet mask
=> 255.255.252.0
R1(config)#ip route 10.0.0.0 255.255.252.0 192.168.12.2
R2(config)#ip route 10.0.0.0 255.255.252.0 192.168.23.1

Related Posts