Menu Đóng

Lab GNS3 Cấu Hình Gán IP

Qui trình gán IP vào interface

– Bước 1: chọn interface để gán IP
+ Xác định các interface đang có trong thiết bị.

R1#show ip interface brief

=> dựa trên kết quả xuất ra của câu lệnh ta xác định tên của các interface.
+ Chọn interface để cấu hình

R1(config)#interface fastethernet 0/0
R1(config-if)#

– Bước 2: Gán địa chỉ IP vào trong interface của thiết bị
+ IP gán vào interface phải thuộc Range-host-ID
+ 1 Interface có thể gán được nhiều địa chỉ IP
+ Đối với router Cisco thì một interface có được một IPv4 dạng primary và có nhiều IP phụ secondary

R1(config-if)#ip address 192.168.1.1 255.255.255.0

=> Gán IP primary cho interface.

R1(config-if)#ip address 192.168.1.2 255.255.255.0 secondary

=> Gán thêm IP secondary cho interface.

R1(config-if)#ip address 192.168.1.3 255.255.255.0 secondary

=> gán thêm IP secondary

– Bước 3: Kích hoạt cho interface hoạt động.
+ Mặc định tất cả các interface vật lý đều ở trạng thái shutdown
+ Để kích hoạt cho interface hoạt động ta sử dụng câu lệnh “no shutdown”

R1(config-if)# no shutdown
R1(config-if)# exit

– Tóm tắt lại các câu lệnh phải nhớ và các số subnet mask tương ứng địa chỉ đường mạng.

R1(config)#interface fastethernet 0/0
R1(config-if)#ip address 192.1.12.1 255.255.255.252
R1(config-if)#no shutdown
R1(config-if)#exit

/21 255.255.248.0
/22 255.255.252.0
/23 255.255.254.0
/24 255.255.255.0
/25 255.255.255.128
/26 255.255.255.192
/27 255.255.255.224
/28 255.255.255.240
/29 255.255.255.248
/30 255.255.255.252

Lab cấu hình gán IP theo sơ đồ

– Sơ đồ bài lab:

– Cấu hình gán IP cho Router 1

R1>enable
R1#conf t
R1(config)#interface f0/0
R1(config-if)#ip address 192.1.12.1 255.255.255.252
R1(config-if)#no shutdown
R1(config-if)#exit

– Cấu hình gán IP cho Router 2

R2>enable
R2#conf t
R2(config)#interface f0/0
R2(config-if)#ip address 192.1.12.2 255.255.255.252
R2(config-if)#no shutdown
R2(config-if)#exit

– Kiểm tra trạng thái hoạt động của các interface

R1#show ip int br
Interface IP-Address OK? Method Status Protocol
FastEthernet0/0 192.168.12.1 YES NVRAM up up
R1# show running-config interface f0/0

– Cấu hình gán IP vào interface fastethernet 0/1 của Router 1

R1(config)# interface fa 0/1
R1(config-if)# ip add 192.168.100.254 255.255.255.0
R1(config-if)# no shutdown
R1(config-if)# exit

– Dòng lệnh cấu hình gán IP ở trong máy Linux
username: tc

tc@box: ~$ sudo su

=> chuyển qua user root ở trong máy linux

root@box:~# ifconfig eth0 192.168.100.1/24 up

=> Gán IP vào trong card mạng eth0 là 192.168.100.1/24

root@box:~# ping 192.168.100.254

=> ping thành công

root@box:~# ping 192.1.12.1

=> Fail lý do “thiếu default gateway trong phần cấu hình gán IP”

root@box:~# route add default gw 192.168.100.254

=> thiết lập default gateway cho máy linux

root@box:~# ping 192.1.12.1

=> ping thành công

Related Posts