Menu Đóng

LAB GNS3 Thực Hành Định Tuyến RIP

Giao thức định tuyến RIP

– Một vài đặc điểm của RIP:
+ RIP là một giao thức distance-vector điển hình. Mỗi router sẽ gửi toàn bộ bảng định tuyến của nó cho router láng giềng theo định kỳ 30s/lần. Láng giềng sau khi xử lý thông tin nhận được, tiếp tục thực hiện quảng bá cho các láng giềng khác và cứ thế lan truyền ra mọi router trên toàn mạng. Kiểu trao đổi thông tin như thế còn được gọi là “lan truyền theo tin đồn”.
+ Metric trong RIP được tính theo hop count, là số router nằm giữa router đang xét và đích đến. Với RIP, giá trị metric tối đa là 15, giá trị metric=16 được gọi là infinity metric (metric vô hạn), có nghĩa là nếu mạng đích đến cách router đang xét từ 16 router trở lên, nó được xem là không thể đi đến được
+ Các gói tin RIP được đóng gói vào các datagram UDP, sử dụng source port và destination port là 520
+ Cách hoạt động của RIP có thể dẫn đến loop nên một số quy tắc chống loop và một số timer được đưa ra. Các quy tắc này làm giảm tốc độ hội tụ của RIP.
+ Với router Cisco, AD của RIP là 120

– So sánh giữa RIPv1 và RIPv2:
+ RIPv1 là một giao thức classful trong khi RIPv2 là một giao thức classless. Các giao thức classful có nhiều điểm hạn chế nên ngày nay các tiến trình RIP được chạy chủ yếu là RIPv2
+ RIPv1 sử dụng địa chỉ broadcast 255.255.255.255 để gửi đi các bản tin cập nhập trong khi RIPv2 sử dụng địa chỉ multicast 224.0.0.9 để gửi đi các bản tin cập nhập
+ RIPv1 không hỗ trợ xác thực trong định tuyến trong khi RIPv2 có hỗ trợ xác thực. Điều này dẫn đến những nguy cơ bảo mật khi sử dụng RIPv1

Sơ đồ bài lab

Cấu hình gán IP theo sơ đồ

– Router 1
//R1
conf t
int f 0/0
ip add 192.1.12.1 255.255.255.252
no sh
int fa 1/0
ip add 172.16.1.254 255.255.255.0
no sh
int lo 0
ip add 1.1.1.1 255.255.255.0
end

– Router 2
//R2
conf t
int fa 0/0
ip add 192.1.12.2 255.255.255.252
no sh
int fa 0/1
ip add 192.1.23.2 255.255.255.252
no sh
end

– Router 3
//R3
conf t
int fa 0/0
ip add 192.1.23.1 255.255.255.252
no sh
int fa 1/0
ip add 172.16.3.254 255.255.255.0
no sh
int lo 0
ip add 3.3.3.3 255.255.255.0
end

Cấu hình định tuyến RIP để các đường mạng trong sơ đồ thấy được nhau

Cấu hình RIPv1

– Cú pháp định tuyến RIP
R1(config)#router rip
=> kích hoạt tính năng RIP
R1(config-router)#network major_classful_network
R1(config-router)#exit
“Bản chất của câu lệnh network là chọn interface tham gia quá trình định tuyến”. Tùy theo mỗi giải thuật định tuyến thì cách routing sẽ khác nhau.

– Định tuyến RIP cho Router 1
R1(config)#router rip
R1(config-router)#network 192.1.12.0
R1(config-router)#network 1.0.0.0
R1(config-router)#network 172.16.0.0
R1(config-router)#exit

– Định tuyến RIP cho Router 2
R2config)#router rip
R2(config-router)#network 192.1.12.0
R2(config-router)#network 2.0.0.0
R2(config-router)#network 192.1.23.0
R2(config-router)#exit

– Định tuyến RIP cho router 3
R3(config)#router rip
R3(config-router)#network 192.1.23.0
R3(config-router)#network 3.0.0.0
R3(config-router)#network 172.16.0.0
R3(config-router)#exit

Cách tính major_classful_network

– Dải mạng 10.1.1.1/30
Network_ID: 10.1.1.0/30
Thuộc Class A
Có Default Subnetmask /8
=> major_classful_network: 10.0.0.0

– Dải mạng 172.16.1.33/27
Network_ID: 172.16.1.32/27
Thuộc Class B
Có Default Subnetmask /16
=> major_classful_network: 172.16.0.0

– Dải mạng 192.168.1.65/27
Network_ID: 192.168.1.64/27
Thuộc Class C
Có Default Subnetmask /24
=> major_classful_network: 192.168.1.0

Cấu hình RIPv2

– Kiểm tra bảng định tuyến tại R2

R2#show ip route rip
R 1.0.0.0/8 [120/1] via 192.1.12.1, 00:00:03, FastEthernet0/0
R 3.0.0.0/8 [120/1] via 192.1.23.1, 00:00:27, FastEthernet0/1
R 172.16.0.0/16 [120/1] via 192.1.23.1, 00:00:27, FastEthernet0/1
[120/1] via 192.1.12.1, 00:00:03, FastEthernet0/0

=> Không thấy được các Network-ID theo đúng sơ đồ mạng thiết kế
=> R2 chỉ thấy được major classful network

– Để ta thấy được “chi tiết các đường mạng theo đúng sơ đồ” thì “ta cấu hình RIPv2 và tắt đi tính năng no auto-summary”
R1(config)#router rip
R1(config-router)#version 2
=> cấu hình router chuyển sang sử dụng RIPv2
=> RIPv2 thì hỗ trợ “gửi thông tin về số subnetmask của các network trong quá trình định tuyến” nhưng do câu lệnh “auto-summary” nên R1 vẫn gửi majorclassful network
R1(config-router)#no auto-summary
R1(config-router)#end

R2(config)#router rip
R2(config-router)#version 2
R2(config-router)#no auto-summary
R2(config-router)#end

R3(config)#router rip
R3(config-router)#version 2
R3(config-router)#no auto-summary
R3(config-router)#end

– Kiểm tra lại

R2#show ip route rip
1.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
R 1.1.1.0/24 [120/1] via 192.1.12.1, 00:00:04, Serial0/0
R 1.0.0.0/8 [120/1] via 192.1.12.1, 00:00:34, Serial0/0
3.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
R 3.3.3.0/24 [120/1] via 192.1.23.1, 00:00:03, Serial0/1
R 3.0.0.0/8 [120/1] via 192.1.23.1, 00:00:31, Serial0/1
172.16.0.0/16 is variably subnetted, 3 subnets, 2 masks
R 172.16.26.0/24 [120/1] via 192.1.12.1, 00:00:04, Serial0/0
R 172.16.0.0/16 [120/1] via 192.1.23.1, 00:00:31, Serial0/1
[120/1] via 192.1.12.1, 00:00:34, Serial0/0
R 172.16.3.0/24 [120/1] via 192.1.23.1, 00:00:03, Serial0/1

– Do RIP có tốc độ hội thụ chậm nên dùng câu lệnh sau để clear bảng định tuyến và tính toán lại
R1#clear ip route *

– Kiểm tra lại:
R1#ping 172.16.3.254 source 172.16.1.254
R1#ping 172.16.1.254 source 172.16.3.254
R1|R2|R3#debug ip rip
R1|R2|R3#undebug all

R2#show ip route rip
1.0.0.0/24 is subnetted, 1 subnets
R 1.1.1.0 [120/1] via 192.1.12.1, 00:00:28, FastEthernet0/0
3.0.0.0/24 is subnetted, 1 subnets
R 3.3.3.0 [120/1] via 192.1.23.1, 00:00:08, FastEthernet0/1
172.16.0.0/24 is subnetted, 2 subnets
R 172.16.1.0 [120/1] via 192.1.12.1, 00:00:28, FastEthernet0/0
R 172.16.3.0 [120/1] via 192.1.23.1, 00:00:08, FastEthernet0/1

Default-Route RIP

– Router 2 kết nối vào card mạng VMnet8 của Cloud1

– Cấu hình gán IP vào interface fa 1/0 của R2. Cấu hình xin dhcp và default route
R2(config)#int fa 1/0
R2(config-if)#ip add dhcp
R2(config-if)#no sh
R2(config-if)#exit

– Router 2 có đường kết nối Internet. R1 R2 R3 giao tiếp với nhau thông qua RIP. R2 thực hiện quá trình quảng cáo “route mặc định” của giao thức RIP
R2(config)#router rip
R2(config-router)#default-information originate
R2(config-router)#exit

– Kiểm tra default route tại R1 và R3
R1#show ip route rip
R* 0.0.0.0/0 [120/1] via 192.1.12.2, 00:00:22, FastEthernet0/0
R1#ping 8.8.8.8 source 172.16.1.254
!!!!

Cấu hình DHCP Server

– Cấu hình Router 1 làm DHCP Server cấp IP cho các PC thuộc network 172.16.1.0/24
R1(config)#ip dhcp pool net1
=> tạo ra pool dhcp có tên “net1”
R1(dhcp-config)#network 172.16.1.0 /24
=> định nghĩa đường mạng cấp IP
R1(dhcp-config)#default-router 172.16.1.254
=> giá trị default-gateway
R1(dhcp-config)#dns-server 8.8.8.8 8.8.4.4
=> định nghĩa DNS-Server cho Client
R1(dhcp-config)#exit
R1(config)# ip dhcp excluded-address 172.16.1.1 172.16.1.100
=> định nghĩa dãy IP ta cấp

– Định nghĩa pool DHCP cho network 172.16.3.0/24
R1(config)#ip dhcp pool net3
R1(dhcp-config)#network 172.16.3.0 /24
R1(dhcp-config)#default-router 172.16.3.254
R1(dhcp-config)#dns-server 8.8.8.8
R1(dhcp-config)#exit
R1(config)#ip dhcp excludedaddress 172.16.3.1 172.16.3.100

– Sử dụng máy Linux-Tiny Core
username: tc
tc@box: ~$ sudo su
=> chuyển qua user Root
tc@box: ~# dhclient eth0
=> xin IP DHCP
tc@box: ~# ifconfig eth0
=> kiểm tra IP ở card mạng eth0
tc@box: ~# route
=> kiểm tra thông số default gateway
tc@box: ~# cat /etc/resolv.conf
=> kiểm tra thông số DNS Server

– Cấu hình tính năng “ip helper-address” trên Router 3. Để R3 cho gói tin DHCP Discovery broadcast từ máy client đi qua. R3 sẽ chuyển gói tin này thành gói tin DHCP Discovery unicast với IP src: 172.16.3.254, IP des:1.1.1.1
R3(config)#int fa 1/0
R3(config-if)#ip helper-address 1.1.1.1

– Kiểm tra
+ kiểm tra các IP đã được cấp phát tương ứng với MAC address của card mạng
R1#show ip dhcp binding
+ Clear lại bảng dhcp đã cấp phát
R1#clear ip dhcp binding *

Related Posts