Thứ Hai , Tháng Ba 4 2024

Lab GNS3 Etherchannel, Trunking, VTP, Spanning Tree, InterVlan

Sơ đồ bài lab

Cấu hình Trunking các đường link giữa switch và switch

– Tắt đi tất cả các interface không sử dụng trên tất cả các switch
//IOU1 IOU2 IOU3 IOU4
conf t
int range ethernet 0/0-3 , ethernet 1/0-3 , ethernet 2/0-3 , ethernet 3/0-3
shutdown
end

//IOU1 IOU2
conf t
int range ethernet 0/0-3 , ethernet 2/2 , ethernet 0/2-3
switchport trunk encapsulation dot1q
switchport mode trunk
no shutdown
end

//IOU3 IOU4
conf t
int range ethernet 0/2-3
switchport trunk encapsulation dot1q
switchport mode trunk
no shutdown
end

– Kiểm tra trạng thái trunking của các interface

IOU1#show interfaces trunk

Port Mode Encapsulation Status Native vlan
Et0/0 on 802.1q trunking 1
Et0/1 on 802.1q trunking 1
Et0/2 on 802.1q trunking 1
Et0/3 on 802.1q trunking 1
Et2/2 on 802.1q trunking 1

Port Vlans allowed on trunk
Et0/0 1-4094
Et0/1 1-4094
Et0/2 1-4094
Et0/3 1-4094
Et2/2 1-4094

Port Vlans allowed and active in management domain
Et0/0 1
Et0/1 1
Et0/2 1
Et0/3 1
Et2/2 1

Port Vlans in spanning tree forwarding state and not pruned

Port Vlans in spanning tree forwarding state and not pruned
Et0/0 1
Et0/1 1
Et0/2 1
Et0/3 1
Et2/2 1

Cấu hình Etherchannel

– cấu hình Etherchannel 2 link kết nối IOU1 và IOU2
//IOU1 IOU2
conf t
int range ethernet 0/0-1
shutdown
channel-protocol lacp
channel-group 1 mode active
no shutdown
end

– Kiểm tra các port channel trên SW

IOU1#show etherchannel summary
Flags: D - down P - bundled in port-channel
I - stand-alone s - suspended
H - Hot-standby (LACP only)
R - Layer3 S - Layer2
U - in use f - failed to allocate aggregator

M - not in use, minimum links not met
u - unsuitable for bundling
w - waiting to be aggregated
d - default port

Number of channel-groups in use: 1
Number of aggregators: 1

Group Port-channel Protocol Ports
------+-------------+-----------+-----------------------------------------------
1 Po1(SU) LACP Et0/0(P) Et0/1(P)

– Kiểm tra trạng thái trunking của các interface

IOU1#show interfaces trunk

Port Mode Encapsulation Status Native vlan
Et0/2 on 802.1q trunking 1
Et0/3 on 802.1q trunking 1
Et2/2 on 802.1q trunking 1
Po1 on 802.1q trunking 1

Port Vlans allowed on trunk
Et0/2 1-4094
Et0/3 1-4094
Et2/2 1-4094
Po1 1-4094

Port Vlans allowed and active in management domain
Et0/2 1
Et0/3 1
Et2/2 1
Po1 1

Port Vlans in spanning tree forwarding state and not pruned
Et0/2 1
Et0/3 1
Et2/2 1

Port Vlans in spanning tree forwarding state and not pruned
Po1 1

– Kiểm tra băng thông trên các port etherchannel
IOU1#show int port-channel 1
… BW 20000 Kbit/sec…

Cấu hình VTP (Virtual Trunking Protocol)

– Mục đích: Đồng bộ thông tin VLan trong mạng. Điều kiện: tất cả kết nối giữa các SW đều phải là đường trunk.

– VTP có 3 mode hoạt động
+ Mode server: Tạo chỉnh sửa xóa thông tin vlan. Tạo ra thông điệp VTP và send. Nhận thông điệp VTP và fordward trên đường trunk. Đồng bộ, đọc thông tin VTP và sử dụng

+ Mode client: Không: tạo chỉnh sửa xóa thông tin vlan.Tạo ra thông điệp VTP và send. Nhận thông điệp VTP và fordward trên đường trunk. Đồng bộ, đọc thông tin VTP và sử dụng

+ Mode transparent: Tạo chỉnh sửa xóa thông tin vlan, nhưng thông tin vlan này chỉ có tác dụng trong local. Không: Tạo ra thông điệp VTP và send. Nhận thông điệp VTP và fordward trên đường trunk. Không: Đồng bộ, đọc thông tin VTP và sử dụng

– Cấu hình VTP tại IOU1
+ VTP Domain: thanhdd
+ Pass: 123
+ Mode: VTP server
+ vtp pruning: Tính năng này giúp sw giảm thiểu việc phải fordward các dữ liệu của các vlan ko tồn tại trên các port access của sw
conf t
vtp domain thanhdd
vtp password 123
vtp mode server

– Cấu hình VTP tại IOU2 IOU3 IOU4
+ Mode: VTP client
+ VTP Domain: thanhdd
+ Pass: 123
conf t
vtp domain thanhdd
vtp password 123
vtp mode client

– Kiểm tra

IOU1#show vtp status
VTP Version capable : 1 to 3
VTP version running : 1
VTP Domain Name : thanhdd
VTP Pruning Mode : Enabled
VTP Traps Generation : Disabled
Device ID : aabb.cc00.0100
Configuration last modified by 0.0.0.0 at 9-28-22 17:38:08
Local updater ID is 0.0.0.0 (no valid interface found)

Feature VLAN:
--------------
VTP Operating Mode : Server
Maximum VLANs supported locally : 1005
Number of existing VLANs : 5
Configuration Revision : 1
MD5 digest : 0xF8 0xF7 0x7C 0xBC 0x6D 0x15 0xDE 0x28
0xB5 0x05 0x2F 0xCB 0x6A 0xD1 0x2A 0x58
IOU1#show vtp password
VTP Password: 123
IOU3#show vtp status
VTP Version capable : 1 to 3
VTP version running : 1
VTP Domain Name : thanhdd
VTP Pruning Mode : Enabled
VTP Traps Generation : Disabled
Device ID : aabb.cc00.0300
Configuration last modified by 0.0.0.0 at 9-28-22 17:38:08

Feature VLAN:
--------------
VTP Operating Mode : Client
Maximum VLANs supported locally : 1005
Number of existing VLANs : 5
Configuration Revision : 1
MD5 digest : 0xF8 0xF7 0x7C 0xBC 0x6D 0x15 0xDE 0x28
0xB5 0x05 0x2F 0xCB 0x6A 0xD1 0x2A 0x58

– Cấu hình IP quản lý cho các SW
+ IOU1: 10.0.0.1/24 – int vlan 1
+ IOU2: 10.0.0.2/24 – int vlan 1
+ IOU3: 10.0.0.3/24 – int vlan 1
+ IOU4: 10.0.0.4/24 – int vlan 1

IOU1#conf t
IOU1(config)#int vlan 1
IOU1(config-if)#ip address 10.0.0.1 255.255.255.0
IOU1(config-if)#no shutdown

– Tại IOU1 thử tạo ra các Vlan 2,3,4
//IOU1
conf t
vlan 2
name Ke_toan
vlan 3
name Hanh_chinh
vlan 4
name Ky_thuat
+ Kiểm tra: Thấy cổng trunk không thuộc Vlan nào. Các SW STP client được đồng bộ giống với VTP server

IOU1#show vlan
...
1 default active Et1/0, Et1/1, Et1/2, Et1/3
Et2/0, Et2/1, Et2/3, Et3/0
Et3/1, Et3/2, Et3/3
2 Ke_toan active
3 Hanh_chinh active
4 Ky_thuat active
...
IOU2#show vlan
...
1 default active Et1/0, Et1/1, Et1/2, Et1/3
Et2/0, Et2/1, Et2/3, Et3/0
Et3/1, Et3/2, Et3/3
2 Ke_toan active
3 Hanh_chinh active
4 Ky_thuat active
...
IOU1#show vtp status
...
Configuration Revision : 4
...

Số Configuration Revision rất quan trọng. VTP server mỗi lần thay đổi thông tin vlan. số này tăng lên một đơn vị và đồng bộ trong mạng

Cấu hình Spanning Tree (STP)

Lab cấu hình Vlan STP

– Spanning Tree được sử dụng để chống Loop ở trong hệ thống SW

– Kiểm tra thông số Spanning Tree của Vlan 1 ở trên các SW của hệ thông
+ Bước 1: Các định địa chỉ mac và priority của các SW
+ Bước 2: Xác định Root Switch
+ Bước 3: Xác định các port là Root port ở các SW đóng vai trò là non-root-switch
+ Bước 4: Xác định các port là Designated Port và Non-Designated-Port tại các phân đoạn

IOU1#show spanning-tree vlan 1
...
Root ID Priority 32769
Address aabb.cc00.0100
This bridge is the root
...
IOU2#show spanning-tree vlan 1
...
Root ID Priority 32769
Address aabb.cc00.0100
Cost 56
Port 65 (Port-channel1)
....
Bridge ID Priority 32769 (priority 32768 sys-id-ext 1)
Address aabb.cc00.0200
....
IOU3#show spanning-tree vlan 1
...
Address aabb.cc00.0300
...
IOU4#show spanning-tree vlan 1
...
Address aabb.cc00.0400
...

Ta thấy IOU1 có Priority bằng các SW khác, mac nhỏ nhất nên tự động được bầu chọn làm root SW

– Cấu hình IOU1 là root switch của Vlan 1 Vlan 3 và làm root switch dự phòng của Vlan2 Vlan4. Cấu hình IOU2 là root switch của Vlan 2 Vlan 4 và làm root switch dự phòng của Vlan1 Vlan3.
//IOU1
spanning-tree vlan 1 root primary
spanning-tree vlan 3 root primary
spanning-tree vlan 2 root secondary
spanning-tree vlan 4 root secondary
//IOU2
spanning-tree vlan 2 root primary
spanning-tree vlan 4 root primary
spanning-tree vlan 1 root secondary
spanning-tree vlan 3 root secondary
+ Kiểm tra
//IOU1 IOU2
show spanning-tree
Tắt IOU1 và show spanning-tree trên IOU2. Sau đó on IOU1 và show spanning-tree trên IOU1 và IOU2

Cú pháp câu lệnh cấu hình STP

– Bật /tắt STP trên các Vlan. Mặc định STP được bật trên mọi Vlan
(config)#[no] spanning-tree vlan VLAN_ID
– Cấu hình SW trở thành root-switch
(config)#spanning-tree vlan VLAN_ID root [primary|secondary] + primary: sw sẽ trở thành root-switch cho Vlan VLAN_ID
+ secondary: sw sẽ trở thành dự phòng cho root-switch trên Vlan VLAN_ID
– Hiệu chỉnh priority cho sw. Hiệu chỉnh giá trị priority cho sw trên Vlan VLAN_ID. giá trị priority là bội số của 4096
(config)#spanning-tree vlan VLAN_ID priority gia_tri_priority
– Hiệu chỉnh giá trị cost trên cổng. giá trị priority trên cổng là bội số của 16
(config-if)# spanning-tree vlan VLAN_ID port-priority gia_tri_priority
– Hiệu chỉnh các timer của STP
(config)#spanning-tree vlan VLAN_ID hello-time seconds
(config)#spanning-tree vlan VLAN_ID forward-time seconds
(config)#spanning-tree vlan VLAN_ID max-age seconds
– Chọn mode STP trên SW. Mặc định SW cisco hoạt động ở chế độ pVST + (pvst)
(config)#spanning-tree mode [pvst|rapid-pvst|mst]

Cấu hình port-access tại IOU3 IOU4

– IOU3 cấu hình eth1/1 thuộc Vlan2 và eth1/2 thuộc vlan3
//IOU3
int eth1/1
shutdown
switchport mode access
switchport access vlan 2
spanning-tree portfast
spanning-tree bpdufilter enable
no shut
int eth1/2
shutdown
switchport mode access
switchport access vlan 3
spanning-tree portfast
spanning-tree bpdufilter enable
no shut

– IOU4 cấu hình eth1/1 thuộc Vlan2 và eth1/2 thuộc vlan3
//IOU4
int eth1/1
shutdown
switchport mode access
switchport access vlan 2
spanning-tree portfast
spanning-tree bpdufilter enable
no shut
int eth1/2
shutdown
switchport mode access
switchport access vlan 3
spanning-tree portfast
spanning-tree bpdufilter enable
no shut

– Kiểm tra cấu hình port access
//IOU3 IOU4
show vlan

Cấu hình định tuyến các vlan (Inter-Vlan)

Lab định tuyến Vlan với router

– Để định tuyến các vlan cần cấu hình định tuyến giữa các vlan

– Cấu hình mỗi Vlan tương ứng với một đường mạng
+ Vlan1: 10.0.0.0/24
+ Vlan2: 10.0.1.0/24
+ Vlan3: 10.0.2.0/24
+ Vlan4: 10.0.3.1/24

– Cấu hình Inter-Vlan tại Roter 1
//R1
inter f0/0
no ip address
no shutdown
int f0/0.1
encapsulation dot1q 1 native
ip addr 10.0.0.254 255.255.255.0
int f0/0.3
encapsulation dot1q 3
ip addr 10.0.2.254 255.255.255.0
int f0/1
no ip addr
no shutdown
int f0/1.2
encapsulation dot1q 2
ip addr 10.0.1.254 255.255.255.0
int f0/1.4
encapsulation dot1q 4
ip addr 10.0.3.254 255.255.255.0
end

– Kiểm tra
+ Đặt IP trên PC1
tc@box:~$ sudo su
root@box:~# ifconfig eth0 10.0.1.100/24 up
root@box:~# route add default gw 10.0.1.254
+ Đặt IP trên PC2
tc@box:~$ sudo su
root@box:~# ifconfig eth0 10.0.2.100/24 up
root@box:~# route add default gw 10.0.2.254
– Ping kiểm
//PC1
ping 10.0.2.100
//PC2
ping 10.0.1.100

Định tuyến VLAN với SW lớp 3

– Bật chức năng định tuyến
(config)#ip routing

– cấu hình IP các interface vlan
(config)#int vlan 1
(config-if)#ip address 10.0.0.1 255.255.255.0
(config-if)#no shutdown

Về thanhdd